Windows Azure Pack – Implementation Issue – Failed to create VM from sysprep vhdx

I went through another very interesting issue while WAP implementation during stabilizing a WAP production environment, although we able to create standalone virtual machine from different templates, in addition we able to create standalone virtual machine from Windows 2008 R2 sysprep vhdx, however the issue that WAP failed to create standalone virtual machine from Windows 2012 R2 sysprep vhdx, error shown in WAP was as follows:

Virtual Machine Manager cannot detect a heartbeat from the specified virtual machine. Either the virtual machine is not running or Virtual Machine Additions is not installed. Verify the status of the virtual machine by connecting to it using Virtual Machine Remote Client (VMRC), and then try the operation again. Please contact your system administrator with this error ID.

When check in SCVMM, error is as follows:

Error (609)

Virtual Machine Manager cannot detect a heartbeat from the specified virtual machine. Either the virtual machine is not running or Virtual Machine Additions is not installed.

Recommended Action

Verify the status of the virtual machine by connecting to it using Virtual Machine Remote Client (VMRC), and then try the operation again.

Good luck in your WAP deployment, and hope that this post will help a lot of consultants while deploying Windows Azure Pack and Service Provider Foundation.

What was little bit different in details of SCVMM error is that the step failed is called “Customize Virtual Machine

So I decided to use the same sysprep vhdx to create a virtual machine from SCVMM, found that the VM creation goes without issues, which means that something send in Windows Azure Pack request who is responsible about the issue.

After some discussions with folks, I realized that maybe something in the WAP plan responsible about virtual machine naming/renaming can be the source of issue, so I decided to go through all the plan settings in WAP admin site, and change the custom settings by selecting “Use template to define computer name” check box as shown in screenshot below,

clip_image002

Once saved the plan, log out & log in to tenant admin site again with one of the tenant administrators accounts, I able to create new VM from the same sysprep vhdx that was giving the error.

So, although error is generated from SCVMM but issue source was from Windows Azure Pack plan, once plan settings be fixed issue was solved.

More Windows Azure Pack solved implementation issues can be found below:

Good luck in your WAP implementation, and be tuned for more solved issues.

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.